To log output using the Linux screen command, you can follow these steps:

Start a screen session by typing screen in your terminal and pressing Enter. Run the command or commands for which you want to log the output. To start logging, press Ctrl + A and then Shift + H. This will activate logging. To stop logging, press Ctrl + A and then Shift + H again. To detach from the screen session without terminating it, press Ctrl + A and then Ctrl + D. To reattach to the screen session later, use the command screen -r. By default, the log file will be named screenlog.X, where X is the screen session number. You can find this file in the directory where you started the screen session. If you want to customize the log file name or location, you can use the -L option followed by the desired file path when starting the screen session.

Here's an example of starting a screen session with logging enabled and specifying a custom log file path:

lua Copy code screen -L /path/to/logfile.log This command will start a screen session with logging enabled, and the output will be saved to /path/to/logfile.log.

Remember to replace /path/to/logfile.log with the actual path and filename you want to use for the log file.

alexlai@opi58G:~$ cat screenlog.0 d

U-Boot 2021.10 (Mar 03 2024 - 10:35:09 -0700)

DRAM: 948 MiB RPI 3 Model B (0xa02082) MMC: mmc@7e202000: 0, mmcnr@7e300000: 1 Loading Environment from FAT... Unable to read "uboot.env" from mmc0:1... In: serial Out: vidconsole Err: vidconsole Net: No ethernet found. starting USB... Bus usb@7e980000: usb dr_mode not found USB DWC2 scanning bus usb@7e980000 for devices... 3 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... libfdt fdt_check_header(): FDT_ERR_BADMAGIC Scanning disk mmc@7e202000.blk... Card did not respond to voltage select! : -110 Scanning disk mmcnr@7e300000.blk... Disk mmcnr@7e300000.blk not ready Found 3 disks Missing RNG device for EFI_RNG_PROTOCOL No EFI system partition BootOrder not defined EFI boot manager: Cannot load any image Found EFI removable media binary efi/boot/bootaa64.efi 227979 bytes read in 13 ms (16.7 MiB/s) libfdt fdt_check_header(): FDT_ERR_BADMAGIC Booting /efi\boot\bootaa64.efi disks: sd0*

OpenBSD/arm64 BOOTAA64 1.18 alexlai@opi58G:~$ cat screenlog.0 d

U-Boot 2021.10 (Mar 03 2024 - 10:35:09 -0700)

DRAM: 948 MiB RPI 3 Model B (0xa02082) MMC: mmc@7e202000: 0, mmcnr@7e300000: 1 Loading Environment from FAT... Unable to read "uboot.env" from mmc0:1... In: serial Out: vidconsole Err: vidconsole Net: No ethernet found. starting USB... Bus usb@7e980000: usb dr_mode not found USB DWC2 scanning bus usb@7e980000 for devices... 3 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... libfdt fdt_check_header(): FDT_ERR_BADMAGIC Scanning disk mmc@7e202000.blk... Card did not respond to voltage select! : -110 Scanning disk mmcnr@7e300000.blk... Disk mmcnr@7e300000.blk not ready Found 3 disks Missing RNG device for EFI_RNG_PROTOCOL No EFI system partition BootOrder not defined EFI boot manager: Cannot load any image Found EFI removable media binary efi/boot/bootaa64.efi 227979 bytes read in 13 ms (16.7 MiB/s) libfdt fdt_check_header(): FDT_ERR_BADMAGIC Booting /efi\boot\bootaa64.efi disks: sd0*

OpenBSD/arm64 BOOTAA64 1.18 boot> boo\alexlai@opi58G:~$ cat screenlog.0 d

U-Boot 2021.10 (Mar 03 2024 - 10:35:09 -0700)

DRAM: 948 MiB RPI 3 Model B (0xa02082) MMC: mmc@7e202000: 0, mmcnr@7e300000: 1 Loading Environment from FAT... Unable to read "uboot.env" from mmc0:1... In: serial Out: vidconsole Err: vidconsole Net: No ethernet found. starting USB... Bus usb@7e980000: usb dr_mode not found USB DWC2 scanning bus usb@7e980000 for devices... 3 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... libfdt fdt_check_header(): FDT_ERR_BADMAGIC Scanning disk mmc@7e202000.blk... Card did not respond to voltage select! : -110 Scanning disk mmcnr@7e300000.blk... Disk mmcnr@7e300000.blk not ready Found 3 disks Missing RNG device for EFI_RNG_PROTOCOL No EFI system partition BootOrder not defined EFI boot manager: Cannot load any image Found EFI removable media binary efi/boot/bootaa64.efi 227979 bytes read in 13 ms (16.7 MiB/s) libfdt fdt_check_header(): FDT_ERR_BADMAGIC Booting /efi\boot\bootaa64.efi disks: sd0*

OpenBSD/arm64 BOOTAA64 1.18 boot> booalexlai@opi58G:~$ tail -f screenlog.0 No EFI system partition BootOrder not defined EFI boot manager: Cannot load any image Found EFI removable media binary efi/boot/bootaa64.efi 227979 bytes read in 13 ms (16.7 MiB/s) libfdt fdt_check_header(): FDT_ERR_BADMAGIC Booting /efi\boot\bootaa64.efi disks: sd0* OpenBSD/arm64 BOOTAA64 1.18 boot> boo I At any prompt except password prompts you can escape to a shell by typing '!'. Default answers are shown in []'s and are selected by pressing RETURN. You can exit this program at any time by pressing Control-C, but this can leave your system in an inconsistent state.

Terminal type? [vt220] System hostname? (short form, e.g. 'foo') rpi3B

Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [bwfm0] Access point? (ESSID, 'any', list# or '?') [any] IPv4 address for bwfm0? (or 'autoconf' or 'none') [autoconf] bwfm0: failed loadfirmware of file brcmfmac43430-sdio.raspberrypi,3-model-b.bin bwfm0: could not init bus No dhcp address on interface bwfm0 in 30 seconds. IPv6 address for bwfm0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] smsc0 Symbolic (host) name for smsc0? [rpi3B] IPv4 address for smsc0? (or 'autoconf' or 'none') [autoconf] IPv6 address for smsc0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] DNS domain name? (e.g. 'example.com') [my.domain] yushei.net Using DNS nameservers at 168.95.192.1 192.168.3.251 8.8.4.4

Password for root account? (will not echo) Password for root account? (again) Start sshd(8) by default? [yes] Setup a user? (enter a lower-case loginname, or 'no') [no] yes No really, what is the lower-case loginname, or 'no'? [no] alexlai Full name for user alexlai? [alexlai] Alex Lai Password for user alexlai? (will not echo) Password for user alexlai? (again) WARNING: root is targeted by password guessing attacks, pubkeys are safer. Allow root ssh login? (yes, no, prohibit-password) [no] yes

Available disks are: sd0. Which disk is the root disk? ('?' for details) [sd0] Encrypt the root disk with a (p)assphrase or (k)eydisk? [no] Disk: sd0 geometry: 3880/255/63 [62333952 Sectors] Offset: 0 Signature: 0xAA55 Starting Ending LBA Info: #: id C H S - C H S [ start: size ]

*0: 0C 2 10 9 - 3 15 12 [ 32768: 16384 ] Win95 FAT32L 1: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 2: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 3: A6 3 15 13 - 5 122 53 [ 49152: 38912 ] OpenBSD Use (W)hole disk or (E)dit the MBR? [whole] Creating a msdos partition and an OpenBSD partition for rest of sd0...done. The auto-allocated layout for sd0 is:

size offset fstype [fsize bsize cpg]

a: 1024.0M 65536 4.2BSD 2048 16384 1 # / b: 1181.9M 2162688 swap
c: 30436.5M 0 unused
d: 1673.8M 4583296 4.2BSD 2048 16384 1 # /tmp e: 2604.9M 8011200 4.2BSD 2048 16384 1 # /var f: 3442.2M 13346048 4.2BSD 2048 16384 1 # /usr g: 966.7M 20395744 4.2BSD 2048 16384 1 # /usr/X11R6 h: 3937.4M 22375488 4.2BSD 2048 16384 1 # /usr/local i: 16.0M 32768 MSDOS
j: 1888.4M 30439200 4.2BSD 2048 16384 1 # /usr/src k: 5896.9M 34306720 4.2BSD 2048 16384 1 # /usr/obj l: 7788.3M 46383552 4.2BSD 2048 16384 1 # /home Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a] A /dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes 6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0l: 7788.3MB in 15950400 sectors of 512 bytes 39 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0d: 1673.8MB in 3427904 sectors of 512 bytes 9 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0f: 3442.2MB in 7049696 sectors of 512 bytes 17 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0g: 966.7MB in 1979744 sectors of 512 bytes 5 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0h: 3937.4MB in 8063712 sectors of 512 bytes 20 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0k: 5896.9MB in 12076832 sectors of 512 bytes 30 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0j: 1888.4MB in 3867520 sectors of 512 bytes 10 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0e: 2604.9MB in 5334848 sectors of 512 bytes 13 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/sd0a (e6264f6b5a2ff867.a) on /mnt type ffs (rw, asynchronous, local) /dev/sd0l (e6264f6b5a2ff867.l) on /mnt/home type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0d (e6264f6b5a2ff867.d) on /mnt/tmp type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0f (e6264f6b5a2ff867.f) on /mnt/usr type ffs (rw, asynchronous, local, nodev) /dev/sd0g (e6264f6b5a2ff867.g) on /mnt/usr/X11R6 type ffs (rw, asynchronous, local, nodev) /dev/sd0h (e6264f6b5a2ff867.h) on /mnt/usr/local type ffs (rw, asynchronous, local, nodev) /dev/sd0k (e6264f6b5a2ff867.k) on /mnt/usr/obj type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0j (e6264f6b5a2ff867.j) on /mnt/usr/src type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0e (e6264f6b5a2ff867.e) on /mnt/var type ffs (rw, asynchronous, local, nodev, nosuid)

Let's install the sets! Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') done Location of sets? (disk http nfs or 'done') [http] disk Is the disk partition already mounted? [no] Available disks are: sd0. Which disk contains the install media? (or 'done') [sd0] a: 2097152 65536 4.2BSD 2048 16384 12960 # /mnt d: 3427904 4583296 4.2BSD 2048 16384 12960 # /mnt/tmp e: 5334848 8011200 4.2BSD 2048 16384 12960 # /mnt/var f: 7049696 13346048 4.2BSD 2048 16384 12960 # /mnt/usr g: 1979744 20395744 4.2BSD 2048 16384 12960 # /mnt/usr/X11R6 h: 8063712 22375488 4.2BSD 2048 16384 12960 # /mnt/usr/local i: 32768 32768 MSDOS
j: 3867520 30439200 4.2BSD 2048 16384 12960 # /mnt/usr/src k: 12076832 34306720 4.2BSD 2048 16384 12960 # /mnt/usr/obj l: 15950400 46383552 4.2BSD 2048 16384 12960 # /mnt/home Available sd0 partitions are: a d e f g h i j k l. Which sd0 partition has the install sets? (or 'done') [a] mount_ffs: /dev/sd0a on /mnt2: Device busy Location of sets? (disk http nfs or 'done') [http] disk Is the disk partition already mounted? [no] Available disks are: sd0. Which disk contains the install media? (or 'done') [sd0] a: 2097152 65536 4.2BSD 2048 16384 12960 # /mnt d: 3427904 4583296 4.2BSD 2048 16384 12960 # /mnt/tmp e: 5334848 8011200 4.2BSD 2048 16384 12960 # /mnt/var f: 7049696 13346048 4.2BSD 2048 16384 12960 # /mnt/usr g: 1979744 20395744 4.2BSD 2048 16384 12960 # /mnt/usr/X11R6 h: 8063712 22375488 4.2BSD 2048 16384 12960 # /mnt/usr/local i: 32768 32768 MSDOS
j: 3867520 30439200 4.2BSD 2048 16384 12960 # /mnt/usr/src k: 12076832 34306720 4.2BSD 2048 16384 12960 # /mnt/usr/obj l: 15950400 46383552 4.2BSD 2048 16384 12960 # /mnt/home Available sd0 partitions are: a d e f g h i j k l. Which sd0 partition has the install sets? (or 'done') [a] done Location of sets? (disk http nfs or 'done') [http] done Are you SURE your install is complete without 'bsd'? [no] Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] ^C

rpi3B# ls /dev MAKEDEV rd0c rwd0b sd0g wd0c bio resolvd.lock rwd0c sd0h wd0d bpf rrd0a rwd0d sd0i wd0e bpf0 rrd0c rwd0e sd0j wd0f cd0a rsd0a rwd0f sd0k wd0g cd0c rsd0b rwd0g sd0l wd0h console rsd0c rwd0h sd0m wd0i cua00 rsd0d rwd0i sd0n wd0j cua01 rsd0e rwd0j sd0o wd0k dhcpleased.lock rsd0f rwd0k sd0p wd0l diskmap rsd0g rwd0l slaacd.lock wd0m klog rsd0h rwd0m stderr wd0n kmem rsd0i rwd0n stdin wd0o ksyms rsd0j rwd0o stdout wd0p mem rsd0k rwd0p tty wskbd0 null rsd0l sd0a tty00 wskbd1 openprom rsd0m sd0b tty01 wskbd2 random rsd0n sd0c ttyC0 zero rcd0a rsd0o sd0d urandom rcd0c rsd0p sd0e wd0a rd0a rwd0a sd0f wd0b rpi3B# ifconfig lo0: flags=2008049<UP,LOOPBACK,RUNNING,MULTICAST,LRO> mtu 32768 llprio 3 groups: lo inet6 ::1 prefixlen 128 inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 inet 127.0.0.1 netmask 0xff000000 bwfm0: flags=808803<UP,BROADCAST,SIMPLEX,MULTICAST,AUTOCONF4> mtu 1500 lladdr 00:00:00:00:00:00 llprio 3 groups: wlan dhcp media: IEEE802.11 autoselect status: no carrier ieee80211: nwid "" smsc0: flags=808843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST,AUTOCONF4> mtu 1500 lladdr b8:27:eb:7d:5f:4a llprio 3 groups: dhcp egress media: Ethernet autoselect (100baseTX full-duplex) status: active inet 192.168.2.201 netmask 0xffffff00 broadcast 192.168.2.255 rpi3B# boot
sh: boot: not found rpi3B# exit erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? A Available network interfaces are: bwfm0 smsc0. Which network interface should be used for the initial DHCP request? (or 'done') [bwfm0] ^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^C

rpi3B# boot sh: boot: not found rpi3B# exit erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? A Available network interfaces are: bwfm0 smsc0. Which network interface should be used for the initial DHCP request? (or 'done') [bwfm0] smsc0 Could not determine auto server. Could not determine auto mode. Response file location? response (I)nstall or (U)pgrade? I Fetching response No response file found; non-interactive mode aborted.

exit

erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? I At any prompt except password prompts you can escape to a shell by typing '!'. Default answers are shown in []'s and are selected by pressing RETURN. You can exit this program at any time by pressing Control-C, but this can leave your system in an inconsistent state.

Terminal type? [vt220] System hostname? (short form, e.g. 'foo') rpi3B

Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [bwfm0] smsc0 IPv4 address for smsc0? (or 'autoconf' or 'none') [autoconf] IPv6 address for smsc0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] DNS domain name? (e.g. 'example.com') [my.domain] yushei.net Using DNS nameservers at 168.95.192.1 192.168.3.251 8.8.4.4

Password for root account? (will not echo) Password for root account? (again) Start sshd(8) by default? [yes] Setup a user? (enter a lower-case loginname, or 'no') [no] yes No really, what is the lower-case loginname, or 'no'? [no] alexlai Full name for user alexlai? [alexlai] Alex Lai Password for user alexlai? (will not echo) Password for user alexlai? (again) WARNING: root is targeted by password guessing attacks, pubkeys are safer. Allow root ssh login? (yes, no, prohibit-password) [no]

Available disks are: sd0. Which disk is the root disk? ('?' for details) [sd0] Encrypt the root disk with a (p)assphrase or (k)eydisk? [no] Disk: sd0 geometry: 3880/255/63 [62333952 Sectors] Offset: 0 Signature: 0xAA55 Starting Ending LBA Info: #: id C H S - C H S [ start: size ]

*0: 0C 2 10 9 - 4 20 16 [ 32768: 32768 ] Win95 FAT32L 1: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 2: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 3: A6 4 20 17 - 3880 27 51 [ 65536: 62268416 ] OpenBSD Use (W)hole disk or (E)dit the MBR? [whole] Creating a msdos partition and an OpenBSD partition for rest of sd0...done. The auto-allocated layout for sd0 is:

size offset fstype [fsize bsize cpg]

a: 1024.0M 65536 4.2BSD 2048 16384 1 # / b: 1181.9M 2162688 swap
c: 30436.5M 0 unused
d: 1673.8M 4583296 4.2BSD 2048 16384 1 # /tmp e: 2604.9M 8011200 4.2BSD 2048 16384 1 # /var f: 3442.2M 13346048 4.2BSD 2048 16384 1 # /usr g: 966.7M 20395744 4.2BSD 2048 16384 1 # /usr/X11R6 h: 3937.4M 22375488 4.2BSD 2048 16384 1 # /usr/local i: 16.0M 32768 MSDOS
j: 1888.4M 30439200 4.2BSD 2048 16384 1 # /usr/src k: 5896.9M 34306720 4.2BSD 2048 16384 1 # /usr/obj l: 7788.3M 46383552 4.2BSD 2048 16384 1 # /home Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a] /dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes 6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0l: 7788.3MB in 15950400 sectors of 512 bytes 39 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0d: 1673.8MB in 3427904 sectors of 512 bytes 9 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0f: 3442.2MB in 7049696 sectors of 512 bytes 17 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0g: 966.7MB in 1979744 sectors of 512 bytes 5 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0h: 3937.4MB in 8063712 sectors of 512 bytes 20 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0k: 5896.9MB in 12076832 sectors of 512 bytes 30 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0j: 1888.4MB in 3867520 sectors of 512 bytes 10 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0e: 2604.9MB in 5334848 sectors of 512 bytes 13 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/sd0a (36f109ea18125b76.a) on /mnt type ffs (rw, asynchronous, local) /dev/sd0l (36f109ea18125b76.l) on /mnt/home type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0d (36f109ea18125b76.d) on /mnt/tmp type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0f (36f109ea18125b76.f) on /mnt/usr type ffs (rw, asynchronous, local, nodev) /dev/sd0g (36f109ea18125b76.g) on /mnt/usr/X11R6 type ffs (rw, asynchronous, local, nodev) /dev/sd0h (36f109ea18125b76.h) on /mnt/usr/local type ffs (rw, asynchronous, local, nodev) /dev/sd0k (36f109ea18125b76.k) on /mnt/usr/obj type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0j (36f109ea18125b76.j) on /mnt/usr/src type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0e (36f109ea18125b76.e) on /mnt/var type ffs (rw, asynchronous, local, nodev, nosuid)

Let's install the sets! Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') done Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') https://mirrors.sonic.net/pub/OpenBSD/ 'https://mirrors.sonic.net/pub/OpenBSD/' is not a valid hostname. HTTP Server? (hostname or 'done') mirrors.sonic.net
Server directory? [pub/OpenBSD/7.5/arm64] Unable to connect using HTTPS; using HTTP instead.

Select sets by entering a set name, a file name pattern or 'all'. De-select sets by prepending a '-', e.g.: '-game*'. Selected sets are labelled '[X]'. [X] bsd [X] base75.tgz [X] game75.tgz [X] xfont75.tgz [X] bsd.mp [X] comp75.tgz [X] xbase75.tgz [X] xserv75.tgz [X] bsd.rd [X] man75.tgz [X] xshare75.tgz Set name(s)? (or 'abort' or 'done') [done] Get/Verify SHA256.sig 100% || 1814 00:00
Signature Verified Get/Verify bsd 100% |
| 17144 KB 00:22
Get/Verify bsd.mp 100% || 17221 KB 00:19
Get/Verify bsd.rd 100% |
| 17932 KB 00:36
Get/Verify base75.tgz 100% || 303 MB 03:57
Get/Verify comp75.tgz 100% |
| 77812 KB 01:36 ^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B Get/Verify man75.tgz 100% || 7870 KB 00:10
Get/Verify game75.tgz 100% |
| 2736 KB 00:06
Get/Verify xbase75.tgz 100% || 50684 KB 00:58
Get/Verify xshare75.tgz 100% |
| 4579 KB 00:05
Get/Verify xfont75.tgz 100% || 22968 KB 00:29
Get/Verify xserv75.tgz 100% |
| 11101 KB 00:18
Installing bsd 100% || 17144 KB 00:03
Installing bsd.mp 100% |
| 17221 KB 00:02
Installing bsd.rd 100% || 17932 KB 00:03
Installing base75.tgz 100% |
| 303 MB 01:55
Extracting etc.tgz 100% || 267 KB 00:01
Installing comp75.tgz 100% |
| 77812 KB 00:53
Installing man75.tgz 100% || 7870 KB 00:09
Installing game75.tgz 100% |
| 2736 KB 00:01
Installing xbase75.tgz 100% || 50684 KB 00:27
Extracting xetc.tgz 100% |
| 7299 00:00
Installing xshare75.tgz 100% || 4579 KB 00:09
Installing xfont75.tgz 100% |
| 22968 KB 00:07
Installing xserv75.tgz 100% |**************************| 11101 KB 00:06
Location of sets? (disk http nfs or 'done') [done] Location of sets? (disk http nfs or 'done') [done] done

What timezone are you in? ('?' for list) [Canada/Mountain] ? Africa/ Eire Jamaica ROK America/ Etc/ Japan Singapore Antarctica/ Europe/ Kwajalein Turkey Arctic/ Factory Libya UCT Asia/ GB MET US/ Atlantic/ GB-Eire MST UTC Australia/ GMT MST7MDT Universal Brazil/ GMT+0 Mexico/ W-SU CET GMT-0 NZ WET CST6CDT GMT0 NZ-CHAT Zulu Canada/ Greenwich Navajo leap-seconds.list Chile/ HST PRC leapseconds Cuba Hongkong PST8PDT posixrules EET Iceland Pacific/ tzdata.zi EST Indian/ Poland EST5EDT Iran Portugal Egypt Israel ROC What timezone are you in? ('?' for list) [Canada/Mountain] Asia/Taipei Saving configuration files... done. Making all device nodes... done. Multiprocessor machine; using bsd.mp instead of bsd. fw_update: add bwfm; update none Relinking to create unique kernel... done.

CONGRATULATIONS! Your OpenBSD install has been successfully completed!

When you login to your new system the first time, please read your mail using the 'mail' command.

Exit to (S)hell, (H)alt or (R)eboot? [reboot] Halt syncing disks... done

The operating system has halted. Please press any key to reboot.

^C alexlai@opi58G:~$ cat screenlog.0 d

U-Boot 2021.10 (Mar 03 2024 - 10:35:09 -0700)

DRAM: 948 MiB RPI 3 Model B (0xa02082) MMC: mmc@7e202000: 0, mmcnr@7e300000: 1 Loading Environment from FAT... Unable to read "uboot.env" from mmc0:1... In: serial Out: vidconsole Err: vidconsole Net: No ethernet found. starting USB... Bus usb@7e980000: usb dr_mode not found USB DWC2 scanning bus usb@7e980000 for devices... 3 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Hit any key to stop autoboot: 0 switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... libfdt fdt_check_header(): FDT_ERR_BADMAGIC Scanning disk mmc@7e202000.blk... Card did not respond to voltage select! : -110 Scanning disk mmcnr@7e300000.blk... Disk mmcnr@7e300000.blk not ready Found 3 disks Missing RNG device for EFI_RNG_PROTOCOL No EFI system partition BootOrder not defined EFI boot manager: Cannot load any image Found EFI removable media binary efi/boot/bootaa64.efi 227979 bytes read in 13 ms (16.7 MiB/s) libfdt fdt_check_header(): FDT_ERR_BADMAGIC Booting /efi\boot\bootaa64.efi disks: sd0*

OpenBSD/arm64 BOOTAA64 1.18 boot> booI At any prompt except password prompts you can escape to a shell by typing '!'. Default answers are shown in []'s and are selected by pressing RETURN. You can exit this program at any time by pressing Control-C, but this can leave your system in an inconsistent state.

Terminal type? [vt220] System hostname? (short form, e.g. 'foo') rpi3B

Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [bwfm0] Access point? (ESSID, 'any', list# or '?') [any] IPv4 address for bwfm0? (or 'autoconf' or 'none') [autoconf] bwfm0: failed loadfirmware of file brcmfmac43430-sdio.raspberrypi,3-model-b.bin bwfm0: could not init bus No dhcp address on interface bwfm0 in 30 seconds. IPv6 address for bwfm0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] smsc0 Symbolic (host) name for smsc0? [rpi3B] IPv4 address for smsc0? (or 'autoconf' or 'none') [autoconf] IPv6 address for smsc0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] DNS domain name? (e.g. 'example.com') [my.domain] yushei.net Using DNS nameservers at 168.95.192.1 192.168.3.251 8.8.4.4

Password for root account? (will not echo) Password for root account? (again) Start sshd(8) by default? [yes] Setup a user? (enter a lower-case loginname, or 'no') [no] yes No really, what is the lower-case loginname, or 'no'? [no] alexlai Full name for user alexlai? [alexlai] Alex Lai Password for user alexlai? (will not echo) Password for user alexlai? (again) WARNING: root is targeted by password guessing attacks, pubkeys are safer. Allow root ssh login? (yes, no, prohibit-password) [no] yes

Available disks are: sd0. Which disk is the root disk? ('?' for details) [sd0] Encrypt the root disk with a (p)assphrase or (k)eydisk? [no] Disk: sd0 geometry: 3880/255/63 [62333952 Sectors] Offset: 0 Signature: 0xAA55 Starting Ending LBA Info: #: id C H S - C H S [ start: size ]

*0: 0C 2 10 9 - 3 15 12 [ 32768: 16384 ] Win95 FAT32L 1: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 2: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 3: A6 3 15 13 - 5 122 53 [ 49152: 38912 ] OpenBSD Use (W)hole disk or (E)dit the MBR? [whole] Creating a msdos partition and an OpenBSD partition for rest of sd0...done. The auto-allocated layout for sd0 is:

size offset fstype [fsize bsize cpg]

a: 1024.0M 65536 4.2BSD 2048 16384 1 # / b: 1181.9M 2162688 swap
c: 30436.5M 0 unused
d: 1673.8M 4583296 4.2BSD 2048 16384 1 # /tmp e: 2604.9M 8011200 4.2BSD 2048 16384 1 # /var f: 3442.2M 13346048 4.2BSD 2048 16384 1 # /usr g: 966.7M 20395744 4.2BSD 2048 16384 1 # /usr/X11R6 h: 3937.4M 22375488 4.2BSD 2048 16384 1 # /usr/local i: 16.0M 32768 MSDOS
j: 1888.4M 30439200 4.2BSD 2048 16384 1 # /usr/src k: 5896.9M 34306720 4.2BSD 2048 16384 1 # /usr/obj l: 7788.3M 46383552 4.2BSD 2048 16384 1 # /home Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a] A /dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes 6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0l: 7788.3MB in 15950400 sectors of 512 bytes 39 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0d: 1673.8MB in 3427904 sectors of 512 bytes 9 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0f: 3442.2MB in 7049696 sectors of 512 bytes 17 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0g: 966.7MB in 1979744 sectors of 512 bytes 5 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0h: 3937.4MB in 8063712 sectors of 512 bytes 20 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0k: 5896.9MB in 12076832 sectors of 512 bytes 30 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0j: 1888.4MB in 3867520 sectors of 512 bytes 10 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0e: 2604.9MB in 5334848 sectors of 512 bytes 13 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/sd0a (e6264f6b5a2ff867.a) on /mnt type ffs (rw, asynchronous, local) /dev/sd0l (e6264f6b5a2ff867.l) on /mnt/home type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0d (e6264f6b5a2ff867.d) on /mnt/tmp type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0f (e6264f6b5a2ff867.f) on /mnt/usr type ffs (rw, asynchronous, local, nodev) /dev/sd0g (e6264f6b5a2ff867.g) on /mnt/usr/X11R6 type ffs (rw, asynchronous, local, nodev) /dev/sd0h (e6264f6b5a2ff867.h) on /mnt/usr/local type ffs (rw, asynchronous, local, nodev) /dev/sd0k (e6264f6b5a2ff867.k) on /mnt/usr/obj type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0j (e6264f6b5a2ff867.j) on /mnt/usr/src type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0e (e6264f6b5a2ff867.e) on /mnt/var type ffs (rw, asynchronous, local, nodev, nosuid)

Let's install the sets! Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') done Location of sets? (disk http nfs or 'done') [http] disk Is the disk partition already mounted? [no] Available disks are: sd0. Which disk contains the install media? (or 'done') [sd0] a: 2097152 65536 4.2BSD 2048 16384 12960 # /mnt d: 3427904 4583296 4.2BSD 2048 16384 12960 # /mnt/tmp e: 5334848 8011200 4.2BSD 2048 16384 12960 # /mnt/var f: 7049696 13346048 4.2BSD 2048 16384 12960 # /mnt/usr g: 1979744 20395744 4.2BSD 2048 16384 12960 # /mnt/usr/X11R6 h: 8063712 22375488 4.2BSD 2048 16384 12960 # /mnt/usr/local i: 32768 32768 MSDOS
j: 3867520 30439200 4.2BSD 2048 16384 12960 # /mnt/usr/src k: 12076832 34306720 4.2BSD 2048 16384 12960 # /mnt/usr/obj l: 15950400 46383552 4.2BSD 2048 16384 12960 # /mnt/home Available sd0 partitions are: a d e f g h i j k l. Which sd0 partition has the install sets? (or 'done') [a] mount_ffs: /dev/sd0a on /mnt2: Device busy Location of sets? (disk http nfs or 'done') [http] disk Is the disk partition already mounted? [no] Available disks are: sd0. Which disk contains the install media? (or 'done') [sd0] a: 2097152 65536 4.2BSD 2048 16384 12960 # /mnt d: 3427904 4583296 4.2BSD 2048 16384 12960 # /mnt/tmp e: 5334848 8011200 4.2BSD 2048 16384 12960 # /mnt/var f: 7049696 13346048 4.2BSD 2048 16384 12960 # /mnt/usr g: 1979744 20395744 4.2BSD 2048 16384 12960 # /mnt/usr/X11R6 h: 8063712 22375488 4.2BSD 2048 16384 12960 # /mnt/usr/local i: 32768 32768 MSDOS
j: 3867520 30439200 4.2BSD 2048 16384 12960 # /mnt/usr/src k: 12076832 34306720 4.2BSD 2048 16384 12960 # /mnt/usr/obj l: 15950400 46383552 4.2BSD 2048 16384 12960 # /mnt/home Available sd0 partitions are: a d e f g h i j k l. Which sd0 partition has the install sets? (or 'done') [a] done Location of sets? (disk http nfs or 'done') [http] done Are you SURE your install is complete without 'bsd'? [no] Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] ^C

rpi3B# ls /dev MAKEDEV rd0c rwd0b sd0g wd0c bio resolvd.lock rwd0c sd0h wd0d bpf rrd0a rwd0d sd0i wd0e bpf0 rrd0c rwd0e sd0j wd0f cd0a rsd0a rwd0f sd0k wd0g cd0c rsd0b rwd0g sd0l wd0h console rsd0c rwd0h sd0m wd0i cua00 rsd0d rwd0i sd0n wd0j cua01 rsd0e rwd0j sd0o wd0k dhcpleased.lock rsd0f rwd0k sd0p wd0l diskmap rsd0g rwd0l slaacd.lock wd0m klog rsd0h rwd0m stderr wd0n kmem rsd0i rwd0n stdin wd0o ksyms rsd0j rwd0o stdout wd0p mem rsd0k rwd0p tty wskbd0 null rsd0l sd0a tty00 wskbd1 openprom rsd0m sd0b tty01 wskbd2 random rsd0n sd0c ttyC0 zero rcd0a rsd0o sd0d urandom rcd0c rsd0p sd0e wd0a rd0a rwd0a sd0f wd0b rpi3B# ifconfig lo0: flags=2008049<UP,LOOPBACK,RUNNING,MULTICAST,LRO> mtu 32768 llprio 3 groups: lo inet6 ::1 prefixlen 128 inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1 inet 127.0.0.1 netmask 0xff000000 bwfm0: flags=808803<UP,BROADCAST,SIMPLEX,MULTICAST,AUTOCONF4> mtu 1500 lladdr 00:00:00:00:00:00 llprio 3 groups: wlan dhcp media: IEEE802.11 autoselect status: no carrier ieee80211: nwid "" smsc0: flags=808843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST,AUTOCONF4> mtu 1500 lladdr b8:27:eb:7d:5f:4a llprio 3 groups: dhcp egress media: Ethernet autoselect (100baseTX full-duplex) status: active inet 192.168.2.201 netmask 0xffffff00 broadcast 192.168.2.255 rpi3B# boot
sh: boot: not found rpi3B# exit erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? A Available network interfaces are: bwfm0 smsc0. Which network interface should be used for the initial DHCP request? (or 'done') [bwfm0] ^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^[[A^C

rpi3B# boot sh: boot: not found rpi3B# exit erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? A Available network interfaces are: bwfm0 smsc0. Which network interface should be used for the initial DHCP request? (or 'done') [bwfm0] smsc0 Could not determine auto server. Could not determine auto mode. Response file location? response (I)nstall or (U)pgrade? I Fetching response No response file found; non-interactive mode aborted.

exit

erase ^?, werase ^W, kill ^U, intr ^C, status ^T

Welcome to the OpenBSD/arm64 7.5 installation program. (I)nstall, (U)pgrade, (A)utoinstall or (S)hell? I At any prompt except password prompts you can escape to a shell by typing '!'. Default answers are shown in []'s and are selected by pressing RETURN. You can exit this program at any time by pressing Control-C, but this can leave your system in an inconsistent state.

Terminal type? [vt220] System hostname? (short form, e.g. 'foo') rpi3B

Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [bwfm0] smsc0 IPv4 address for smsc0? (or 'autoconf' or 'none') [autoconf] IPv6 address for smsc0? (or 'autoconf' or 'none') [none] Available network interfaces are: bwfm0 smsc0 vlan0. Network interface to configure? (name, lladdr, '?', or 'done') [done] DNS domain name? (e.g. 'example.com') [my.domain] yushei.net Using DNS nameservers at 168.95.192.1 192.168.3.251 8.8.4.4

Password for root account? (will not echo) Password for root account? (again) Start sshd(8) by default? [yes] Setup a user? (enter a lower-case loginname, or 'no') [no] yes No really, what is the lower-case loginname, or 'no'? [no] alexlai Full name for user alexlai? [alexlai] Alex Lai Password for user alexlai? (will not echo) Password for user alexlai? (again) WARNING: root is targeted by password guessing attacks, pubkeys are safer. Allow root ssh login? (yes, no, prohibit-password) [no]

Available disks are: sd0. Which disk is the root disk? ('?' for details) [sd0] Encrypt the root disk with a (p)assphrase or (k)eydisk? [no] Disk: sd0 geometry: 3880/255/63 [62333952 Sectors] Offset: 0 Signature: 0xAA55 Starting Ending LBA Info: #: id C H S - C H S [ start: size ]

*0: 0C 2 10 9 - 4 20 16 [ 32768: 32768 ] Win95 FAT32L 1: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 2: 00 0 0 0 - 0 0 0 [ 0: 0 ] Unused 3: A6 4 20 17 - 3880 27 51 [ 65536: 62268416 ] OpenBSD Use (W)hole disk or (E)dit the MBR? [whole] Creating a msdos partition and an OpenBSD partition for rest of sd0...done. The auto-allocated layout for sd0 is:

size offset fstype [fsize bsize cpg]

a: 1024.0M 65536 4.2BSD 2048 16384 1 # / b: 1181.9M 2162688 swap
c: 30436.5M 0 unused
d: 1673.8M 4583296 4.2BSD 2048 16384 1 # /tmp e: 2604.9M 8011200 4.2BSD 2048 16384 1 # /var f: 3442.2M 13346048 4.2BSD 2048 16384 1 # /usr g: 966.7M 20395744 4.2BSD 2048 16384 1 # /usr/X11R6 h: 3937.4M 22375488 4.2BSD 2048 16384 1 # /usr/local i: 16.0M 32768 MSDOS
j: 1888.4M 30439200 4.2BSD 2048 16384 1 # /usr/src k: 5896.9M 34306720 4.2BSD 2048 16384 1 # /usr/obj l: 7788.3M 46383552 4.2BSD 2048 16384 1 # /home Use (A)uto layout, (E)dit auto layout, or create (C)ustom layout? [a] /dev/rsd0a: 1024.0MB in 2097152 sectors of 512 bytes 6 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0l: 7788.3MB in 15950400 sectors of 512 bytes 39 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0d: 1673.8MB in 3427904 sectors of 512 bytes 9 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0f: 3442.2MB in 7049696 sectors of 512 bytes 17 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0g: 966.7MB in 1979744 sectors of 512 bytes 5 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0h: 3937.4MB in 8063712 sectors of 512 bytes 20 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0k: 5896.9MB in 12076832 sectors of 512 bytes 30 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0j: 1888.4MB in 3867520 sectors of 512 bytes 10 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/rsd0e: 2604.9MB in 5334848 sectors of 512 bytes 13 cylinder groups of 202.50MB, 12960 blocks, 25920 inodes each /dev/sd0a (36f109ea18125b76.a) on /mnt type ffs (rw, asynchronous, local) /dev/sd0l (36f109ea18125b76.l) on /mnt/home type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0d (36f109ea18125b76.d) on /mnt/tmp type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0f (36f109ea18125b76.f) on /mnt/usr type ffs (rw, asynchronous, local, nodev) /dev/sd0g (36f109ea18125b76.g) on /mnt/usr/X11R6 type ffs (rw, asynchronous, local, nodev) /dev/sd0h (36f109ea18125b76.h) on /mnt/usr/local type ffs (rw, asynchronous, local, nodev) /dev/sd0k (36f109ea18125b76.k) on /mnt/usr/obj type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0j (36f109ea18125b76.j) on /mnt/usr/src type ffs (rw, asynchronous, local, nodev, nosuid) /dev/sd0e (36f109ea18125b76.e) on /mnt/var type ffs (rw, asynchronous, local, nodev, nosuid)

Let's install the sets! Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') done Location of sets? (disk http nfs or 'done') [http] HTTP proxy URL? (e.g. 'http://proxy:8080', or 'none') [none] (Unable to get list from openbsd.org, but that is OK) HTTP Server? (hostname or 'done') https://mirrors.sonic.net/pub/OpenBSD/ 'https://mirrors.sonic.net/pub/OpenBSD/' is not a valid hostname. HTTP Server? (hostname or 'done') mirrors.sonic.net
Server directory? [pub/OpenBSD/7.5/arm64] Unable to connect using HTTPS; using HTTP instead.

Select sets by entering a set name, a file name pattern or 'all'. De-select sets by prepending a '-', e.g.: '-game*'. Selected sets are labelled '[X]'. [X] bsd [X] base75.tgz [X] game75.tgz [X] xfont75.tgz [X] bsd.mp [X] comp75.tgz [X] xbase75.tgz [X] xserv75.tgz [X] bsd.rd [X] man75.tgz [X] xshare75.tgz Set name(s)? (or 'abort' or 'done') [done] Get/Verify SHA256.sig 100% || 1814 00:00
Signature Verified Get/Verify bsd 100% |
| 17144 KB 00:22
Get/Verify bsd.mp 100% || 17221 KB 00:19
Get/Verify bsd.rd 100% |
| 17932 KB 00:36
Get/Verify base75.tgz 100% || 303 MB 03:57 03:15 ETA Get/Verify comp75.tgz 100% || 77812 KB 01:36 ^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B^[[B Get/Verify man75.tgz 100% || 7870 KB 00:10
Get/Verify game75.tgz 100% |
| 2736 KB 00:06
Get/Verify xbase75.tgz 100% || 50684 KB 00:58
Get/Verify xshare75.tgz 100% |
| 4579 KB 00:05
Get/Verify xfont75.tgz 100% || 22968 KB 00:29
Get/Verify xserv75.tgz 100% |
| 11101 KB 00:18
Installing bsd 100% || 17144 KB 00:03
Installing bsd.mp 100% |
| 17221 KB 00:02
Installing bsd.rd 100% || 17932 KB 00:03
Installing base75.tgz 100% |
| 303 MB 01:55
Extracting etc.tgz 100% || 267 KB 00:01
Installing comp75.tgz 100% |
| 77812 KB 00:53
Installing man75.tgz 100% || 7870 KB 00:09
Installing game75.tgz 100% |
| 2736 KB 00:01
Installing xbase75.tgz 100% || 50684 KB 00:27
Extracting xetc.tgz 100% |
| 7299 00:00
Installing xshare75.tgz 100% || 4579 KB 00:09
Installing xfont75.tgz 100% |
| 22968 KB 00:07
Installing xserv75.tgz 100% |**************************| 11101 KB 00:06
Location of sets? (disk http nfs or 'done') [done] Location of sets? (disk http nfs or 'done') [done] done

What timezone are you in? ('?' for list) [Canada/Mountain] ? Africa/ Eire Jamaica ROK America/ Etc/ Japan Singapore Antarctica/ Europe/ Kwajalein Turkey Arctic/ Factory Libya UCT Asia/ GB MET US/ Atlantic/ GB-Eire MST UTC Australia/ GMT MST7MDT Universal Brazil/ GMT+0 Mexico/ W-SU CET GMT-0 NZ WET CST6CDT GMT0 NZ-CHAT Zulu Canada/ Greenwich Navajo leap-seconds.list Chile/ HST PRC leapseconds Cuba Hongkong PST8PDT posixrules EET Iceland Pacific/ tzdata.zi EST Indian/ Poland EST5EDT Iran Portugal Egypt Israel ROC What timezone are you in? ('?' for list) [Canada/Mountain] Asia/Taipei Saving configuration files... done. Making all device nodes... done. Multiprocessor machine; using bsd.mp instead of bsd. fw_update: add bwfm; update none Relinking to create unique kernel... done.

CONGRATULATIONS! Your OpenBSD install has been successfully completed!

When you login to your new system the first time, please read your mail using the 'mail' command.

Exit to (S)hell, (H)alt or (R)eboot? [reboot] Halt syncing disks... done

The operating system has halted. Please press any key to reboot.

alexlai@opi58G:~$ ;142Rとは